OmniSecu.com Logo  
omnisecu.com free mcse ccna rhce linux java learning
omnisecu.com free mcse ccna rhce linux java learning
          Sharefacebook twitter google+ google bookmark yahoo bookmark delicious digg linkedin pinterest reddit stumbleupon evernote diigo blinklist blogmarks livejournal email feed

Tutorials

How to configure and verify Spanning Tree Protocol (STP) PortFast

External Resources

PortFast is a feature which can be used to speed up convergence on ports which are connected to a workstation or a server (which will not cause layer 2 loops).

To configure Spanning Tree Protocol (STP) PortFast on a Switch running IOS, run "spanning-tree portfast" command as shown below.

omnisecu.com.SW1>enable
omnisecu.com.SW1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
omnisecu.com.SW1(config)#interface range fa0/1 - 20
omnisecu.com.SW1(config-if-range)#switchport mode access
omnisecu.com.SW1(config-if-range)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION

%Portfast will be configured in 20 interfaces due to the range command
 but will only have effect when the interfaces are in a non-trunking mode.
omnisecu.com.SW1(config-if-range)#exit
omnisecu.com.SW1(config)#exit

%SYS-5-CONFIG_I: Configured from console by console
omnisecu.com.SW1#

To view the configured Spanning Tree PortFast enabled ports, run the "show running-config" IOS command as shown below. We can see that PortFast is enabled on access ports fa0/1 to fa0/24.

omnisecu.com.SW1#show running-config
Building configuration...

Current configuration : 2003 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname omnisecu.com.SW1
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/5
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/6
 switchport mode access
 spanning-tree portfast
!
<output omitted>

 

To display a detailed summary of interface information, run "show spanning-tree detail" command as shown below.

omnisecu.com.SW1#show spanning-tree detail 

VLAN0001 is executing the ieee compatible Spanning Tree Protocol
  Bridge Identifier has priority of 32768, sysid 1, 00E0.A333.3C56
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32769
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:00:00 ago
	        from FastEthernet0/1
  Times:  hold 1, topology change 35, notification 2
  		hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 1 (FastEthernet0/1) of VLAN0001 is designated forwarding
  Port path cost 19, Port priority 128, Port Identifier 128.1
  Designated bridge has priority 32769, address 00E0.A333.3C56
  Designated port id is 128.1, designated path cost 19
  Timers: message age 16, forward delay 0, hold 0
  Number of transitions to forwarding state: 1
  Link type is point-to-point by default
  <output omitted>

To display Spanning Tree information on active interfaces only, run "show spanning-tree active" IOS command as shown below.

omnisecu.com.SW1#show spanning-tree active 
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     00E0.A333.3C56
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     00E0.A333.3C56
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Desg FWD 19        128.1    P2p
Gi1/2            Desg FWD 4         128.26   P2p
Fa0/2            Desg FWD 19        128.2    P2p
Fa0/3            Desg FWD 19        128.3    P2p
Fa0/4            Desg FWD 19        128.4    P2p
Fa0/5            Desg FWD 19        128.5    P2p
Fa0/6            Desg FWD 19        128.6    P2p
Fa0/7            Desg FWD 19        128.7    P2p
Fa0/8            Desg FWD 19        128.8    P2p
Fa0/9            Desg FWD 19        128.9    P2p
              Jajish Thomason Google+
Related Topics
• What is Broadcast Storm
• What is Layer 2 Switching loop
• What is Spanning Tree Protocol (STP)
• What is Bridge Protocol Data Unit (BPDU) frame
• Bridge Protocol Data Unit (BPDU) Frame Format
• What is a Root Bridge (Switch)
• What is a Root Port
• What are Port Cost, Port Priority and Path Cost Values
• How Spanning Tree Protocol (STP) select Root Port
• What is a Designated Port
• How Spanning Tree Protocol (STP) select Designated Port
• Difference between Root Port and Designated Port
• Spanning Tree Port States
• Topology Changes in Spanning Tree Protocol (STP)
• Spanning Tree Protocol (STP) Convergence
• What is Spanning Tree Protocol (STP) PortFast
How to configure and verify Spanning Tree Protocol (STP) PortFast
• How to enable or disable Spanning Tree Protocol (STP)
• What is Rapid Spanning Tree Protocol (RSTP)
• Difference between Spanning Tree Protocol (STP) and Rapid Spanning Tree Protocol (RSTP)
Per-VLAN Spanning Tree (PVST) and Per-VLAN Spanning Tree Plus (PVST+)
• What are Spanning Tree Bridge Priority and Bridge ID values
• Spanning Tree Path Cost Value and How is Spanning Tree Path Cost Value Calculated
• Spanning Tree Port Priority and Port ID Values
• How to change Spanning Tree Bridge Root Priority value and What is Extended System ID
• How to configure Spanning Tree Protocol Root Primary and Root Secondary
• What is a Root Bridge (Root Switch)
• How to change Spanning Tree Port Priority Value
• How Spanning Tree Protocol (STP) select Root Port
• What is a Designated Port
• How Spanning Tree Protocol (STP) select Designated Port
• Difference between Root Port and Designated Port
• Spanning Tree Port States
• How BPDU is generated and How BPDU works
• Important Spanning Tree Protocol (STP) Timers and their default values
• How to Configure and Change Spanning Tree Protocol (STP) Default Timer-Values for hello timer, forward delay timer and max age timer
• Topology Changes in Spanning Tree Protocol (STP)
• Spanning Tree Protocol (STP) Convergence
• Where to place the Spanning Tree Protocol Root Switch (Root Bridge)
• Spanning Tree Protocol (STP) UplinkFast, Backbone Fast and Portfast
• What is Spanning Tree Protocol (STP) Uplink Fast
• What is Spanning Tree Protocol (STP) Backbone Fast
• What is Spanning Tree Protocol (STP) PortFast
• How to configure and verify Spanning Tree Protocol (STP) PortFast
• How to enable or disable Spanning Tree Protocol (STP)
• What is Rapid Spanning Tree Protocol (RSTP)
• Difference between Spanning Tree Protocol (STP) and Rapid Spanning Tree Protocol (RSTP)
• Per-VLAN Spanning Tree (PVST) and Per-VLAN Spanning Tree Plus (PVST+)
comments powered by Disqus


eXTReMe Tracker DMCA.com